A short story on why you should upgrade to CanJS 4.0


#1

So I’m working on an application and I get this error in the console:

image

Clicking contribution-month.js:314 brings me to this code:

Someone is calling osProjectContributionsMap( ... ) without a currentContributionMonth!!! What a JERK!

Here’s where CanJS 3.0 and 4.0 differ … I add a breakpoint for when there is no currentContributionMonth:

Reload the page, and what do I see:

I see the stache expression that caused the problem! In 3.0, you’d just see some anonymous function.