How to resolve version conflict?



I’ve just updated my npm modules and now I get an error message that there are 2 different versions of can-dom-data-state. How to prevent this? Or is it a bug?

$ npm ls can-dom-data-state
energie_transitie@1.0.0 /src/EnergieTransitie
├─┬ can-component@3.3.6
│ └─┬ can-util@3.10.12
│   └── can-dom-data-state@0.1.1
├─┬ steal-stache@3.1.3
│ └─┬ can-view-import@3.2.5
│   └── can-dom-data-state@0.2.0


There is a can-util@3.10.15 that depends on the updated version of can-dom-data-state.

If you are using a package-lock.json or other lockfile, make sure to delete it and try removing your node_modules and reinstalling completely. There shouldn’t be anything preventing this updated version from being installed.