Issue after updating can-route


#1

I am still running on some 3.* version and tried to update can-route from 3.0.11 to 3.3.4.
I ran npm update can-route in my XYZ/node_modules directory
After doing so the console gives me:

steal.js:3198 GET http://XYZ/node_modules/can-route/node_modules/can-compute/node_modules/can-cid/package.json 404 (Not Found)
steal.js:3198 GET http://XYZ/node_modules/can-route/node_modules/can-util/node_modules/can-cid/package.json 404 (Not Found)
steal.js:7940 Error: You can’t have two versions of can-cid, check your dependencies

    at Object.eval (can-cid.js:55)
    at eval (can-cid.js:60)
    at eval (can-cid.js:60)

Looks like I have now a nested set of node_modules directories. At least the node_modules within can-route was not present before the update.

Any hints how I do the update correctly?

Thx,

Nada

Please describe your question here. Fork this CodePen to make examples.


#2

You can run npm ls can-cid to see what is depending on can-cid.

This error might be fixed by removing your node_modules folder and doing a new npm install.

Also, make sure to delete any package-lock.json or yarn.lock file in your project before running the new install.